forum - Stellaris - Update needed for new game version (3.1 “Lem” Update)

user

Update needed for new game version (3.1 “Lem” Update)

3
by Psydom
Created On 9/14/2021 11:21:00 PM
#1
user
Psydom
Premium Member
7 posts
Hi Team,
A new update for Stellaris has been released, could we ask for an update to the 'ol Plitch to match?
Cheers,
Psy 
1
0
0
#2
user
IronJulia
Team Member
16185 posts
The update is on the to-do list.
1
0
1
#3
user
Deglorath
Premium Member
24 posts
IronJulia
9/15/2021 5:11:17 AM
user

The update is on the to-do list.

Thank you for adding it to the to-do list!
0
0
0
Your Comment
user
😀
You have to be signed in and registered to post a comment!
This website uses cookies to make your visit as userfriendly as possible. For further information please visit our privacy policy statements.