EN
  • EN EN
  • DE DE
  • TR TR
  • FR FR
  • ES ES
  • PL PL

Needs updating 5.0.20257 . - Age of Empires IV

user

Needs updating 5.0.20257 .

7
by X-Ray333
Created On 1/19/2022 10:54:10 PM
#1
user
X-Ray333
Premium Member
19 posts
Please look at it when you can.
0
0
0
#2
user
IronJulia
Team Member
25517 posts
The update is on the to-do list.
0
0
0
#3
user
JJ39
Team Member
781 posts
The latest version is now available in PLITCH.
0
0
0
#4
user
chaselib8
Premium Member
1 posts
new one is 5.0.12973.0
0
0
1
#5
user
IronJulia
Team Member
25517 posts
chaselib8
4/9/2022 5:18:30 AM
user

new one is 5.0.12973.0

is already in the trainer :x
0
0
1
#6
user
shaiss
Premium Member
2 posts
IronJulia
4/9/2022 9:02:55 AM
user

is already in the trainer :x

what do you mean in the trainer?
0
0
0
#7
user
IronJulia
Team Member
25517 posts
Restart the trainer and check again.
version 5.0.12973.0 is already available.
0
0
0
Your Comment
user
😀
You have to be signed in and registered to post a comment!
This website uses cookies to make your visit as userfriendly as possible. For further information please visit our privacy policy statements.