Unable to open Plitch version 1.1.9

avatar frame
ellanteladar37
11 Posts
5/31/2021
15
999+
Do you guys also have this experience? After installing the application to my Desktop PC it's not opening correctly even if I'm running it as Admin.

Any ideas guys?

I really don't know why it kept loading always without letting me logged in as a member



My PC specs are:

OS: Windows 10 Pro 64-bit version 20H2
CPU: Intel i3-8100  @3.60GHz
RAM: HyperXFury 16GB
Video Card: AMD RX 570 8GB GDDR5
Storage: 465GB NVMe (2x)  --  which is literally 1TB
Storage: 1.81GB HDD  -- which is literally 2TB

5/31/2021
15
999+
avatar frame
ellanteladar37
11 posts
Do you guys also have this experience? After installing the application to my Desktop PC it's not opening correctly even if I'm running it as Admin.

Any ideas guys?

I really don't know why it kept loading always without letting me logged in as a member



My PC specs are:

OS: Windows 10 Pro 64-bit version 20H2
CPU: Intel i3-8100  @3.60GHz
RAM: HyperXFury 16GB
Video Card: AMD RX 570 8GB GDDR5
Storage: 465GB NVMe (2x)  --  which is literally 1TB
Storage: 1.81GB HDD  -- which is literally 2TB

avatar frame
IronJulia
41302 Posts
#1
5/31/2021
Please repair your trainer by downloading the plitch utilities tool
You can find the tool in the faq in the "MY PLITCH IS STUCK IN THE LOADING SCREEN?!" section
https://www.plitch.com/en/FAQ
0 0
#1
5/31/2021
avatar frame
IronJulia
41302 Posts
Please repair your trainer by downloading the plitch utilities tool
You can find the tool in the faq in the "MY PLITCH IS STUCK IN THE LOADING SCREEN?!" section
https://www.plitch.com/en/FAQ
0 0
avatar frame
ellanteladar37
11 Posts
#2
6/1/2021
5/31/2021 IronJulia wrote

Please repair your trainer by downloading the plitch utilities tool
You can find the tool in the faq in the "MY PLITCH IS STUCK IN THE LOADING SCREEN?!" section
https://www.plitch.com/en/FAQ
Ok IronJulia I've recently download it today and clicked Rebuild WMI button however it keeps loading the same as usual. 

I've already reinstalled the application 7x already and then run the Rebuild WMI button again still no progress of working at all.

It kept loading and loading and loading until eternity.

The last time it worked when I first installed it and when I accidentally uninstalled the Plitch application the loading screen kept loading and loading.
0 0
#2
6/1/2021
avatar frame
ellanteladar37
11 Posts
5/31/2021 IronJulia wrote

Please repair your trainer by downloading the plitch utilities tool
You can find the tool in the faq in the "MY PLITCH IS STUCK IN THE LOADING SCREEN?!" section
https://www.plitch.com/en/FAQ
Ok IronJulia I've recently download it today and clicked Rebuild WMI button however it keeps loading the same as usual. 

I've already reinstalled the application 7x already and then run the Rebuild WMI button again still no progress of working at all.

It kept loading and loading and loading until eternity.

The last time it worked when I first installed it and when I accidentally uninstalled the Plitch application the loading screen kept loading and loading.
0 0
avatar frame
IronJulia
41302 Posts
#3
6/1/2021
What is loading?
The game trainer for league of maidens or the trainer itself?
0 0
#3
6/1/2021
avatar frame
IronJulia
41302 Posts
What is loading?
The game trainer for league of maidens or the trainer itself?
0 0
avatar frame
ellanteladar37
11 Posts
#4
6/1/2021
@captain4wes0me

Captain any ideas on how to fix Plitch Unable to let me go to the login and password page while it keeps loading for hours?

IronJulia helped me with the tools in the: https://www.plitch.com/en/FAQ

I've looked on " MY PLITCH IS STUCK IN THE LOADING SCREEN?! " Section yet it's not still working after reinstalling 7x and did the Rebuild WMI button.

After that, it's still not working at all 😐😐😐😐😐😐😐
0 0
#4
6/1/2021
avatar frame
ellanteladar37
11 Posts
@captain4wes0me

Captain any ideas on how to fix Plitch Unable to let me go to the login and password page while it keeps loading for hours?

IronJulia helped me with the tools in the: https://www.plitch.com/en/FAQ

I've looked on " MY PLITCH IS STUCK IN THE LOADING SCREEN?! " Section yet it's not still working after reinstalling 7x and did the Rebuild WMI button.

After that, it's still not working at all 😐😐😐😐😐😐😐
0 0
avatar frame
ellanteladar37
11 Posts
#5
6/1/2021
5/31/2021 IronJulia wrote

Please repair your trainer by downloading the plitch utilities tool
You can find the tool in the faq in the "MY PLITCH IS STUCK IN THE LOADING SCREEN?!" section
https://www.plitch.com/en/FAQ
Is it ok that it's installed on a different drive?

Like not in Local Drive C:

I've installed on my 3rd Drive which is E:

Is this an issue of not letting Plitch work properly IronJulia? 
0 0
#5
6/1/2021
avatar frame
ellanteladar37
11 Posts
5/31/2021 IronJulia wrote

Please repair your trainer by downloading the plitch utilities tool
You can find the tool in the faq in the "MY PLITCH IS STUCK IN THE LOADING SCREEN?!" section
https://www.plitch.com/en/FAQ
Is it ok that it's installed on a different drive?

Like not in Local Drive C:

I've installed on my 3rd Drive which is E:

Is this an issue of not letting Plitch work properly IronJulia? 
0 0
avatar frame
captain4wes0me
2784 Posts
#6
6/1/2021
Which Antivirus and Firewall are you using?
Please copy this into your explorer:
%localappdata%\MegaDev\Plitch\Data

Delete everything in that folder!
0 0
#6
6/1/2021
avatar frame
captain4wes0me
2784 Posts
Which Antivirus and Firewall are you using?
Please copy this into your explorer:
%localappdata%\MegaDev\Plitch\Data

Delete everything in that folder!
0 0
You have to be signed in and registered to post a comment!
An error has occurred. This app may no longer respond until reloaded. Reload 🗙